#1020 closed defect (duplicate)

"timeout" missing in legal config options (used by munin-update)

Reported by: blueyed Owned by: nobody
Priority: normal Milestone: Munin 1.4.6
Component: master Version: devel
Severity: normal Keywords:
Cc:

Description

It looks to me like "timeout" is missing from the list of legal config keywords in common/lib/Munin/Common/Config.pm (http://munin-monitoring.org/browser/trunk/common/lib/Munin/Common/Config.pm).

It appears to be used by munin-update.

I have not looked deeper into this yet, but I would like to only define a timeout for the initial connection, and not for the whole fetch process (which might take longer).
Is this what will happen here when using timeout with "munin-update" / via global config?

These should timeout after 5s max: Failed to connect to node 10.122.x.y:4949/tcp : Connection timed out (quite a lot of nodes might be temporarily down).

Change History (2)

comment:1 Changed at 2011-01-26T00:27:57+01:00 by blueyed

Sorry, this is a duplicate of bug #1021.

comment:2 Changed at 2011-02-15T00:04:28+01:00 by ligne

  • Resolution set to duplicate
  • Status changed from new to closed

yeah, i'd just spotted that :-)

resolving DUPLICATE.

Note: See TracTickets for help on using tickets.