#1156 closed defect (duplicate)

munin-cgi-graph does not honor config file overrides when run as FastCGI

Reported by: karavelov Owned by: nobody
Priority: normal Milestone: Munin 3.0.0
Component: web-interface Version: 2.0-alpha2
Severity: normal Keywords: fastcgi munin-cgi-graph
Cc:

Description

If we override some graph_titles in minin.conf, the first run of munin-cgi-graph (after respawning the fastcgi processes and deleting the old PNGs) sets the titles correctly, but in next runs they are reset back to generic names.

Example munin.conf:
[gw.internal]

address = 10.0.0.1
if_eth0.graph_title External traffic
if_eth1.graph_title Internal traffic

Change History (5)

comment:1 Changed at 2011-10-24T08:12:37+02:00 by karavelov

Ok, the example munin.conf is here again, properly marked:

[gw.internal]
   address = 10.0.0.1
   if_eth0.graph_title External traffic
   if_eth1.graph_title Internal traffic

comment:2 Changed at 2011-10-26T19:14:54+02:00 by karavelov

If we comment

   $config = munin_readconfig("$config->{dbdir}/datafile");

in sub munin_refreshconfig (Munin::Master::Utils line 974) the defect goes away but we need to restart fastcgi service on every change to config file.

comment:3 Changed at 2012-02-02T16:20:27+01:00 by snide

  • Milestone changed from Munin 2.0 to Munin 3.0

You have to wait until m-u updates the datafile. The cgi shall not read the config files, for performance and atomicity reasons

The fact that it currently does is a bug, that's why I don't close it, but push it to 3.0.

comment:4 Changed at 2012-09-13T23:18:49+02:00 by ze

Note: this is a special case of 1255.

Patches are on their way, please check 1255 (munin-cgi-graph (fastcgi) forget values on reload) for more details.

comment:5 Changed at 2012-09-15T13:56:26+02:00 by holger

  • Resolution set to duplicate
  • Status changed from new to closed

resolving as duplicate of 1255

Note: See TracTickets for help on using tickets.