#1719 new defect

munin-cgi-html: Can't use an undefined value as an ARRAY reference at /usr/lib64/perl5/vendor_perl/5.20.1/Munin/Master/HTMLOld.pm line 694

Reported by: montjoie Owned by: nobody
Priority: normal Milestone:
Component: web-interface Version: 2.0.21
Severity: major Keywords:
Cc:

Description

I have configured the displaying to the cgi mode.
When I try to get main index, the following error is displayed instead:
Software error:
Can't use an undefined value as an ARRAY reference at /usr/lib64/perl5/vendor_perl/5.20.1/Munin/Master/HTMLOld.pm line 694.

The following lines could be found in apache logs:
[Fri Feb 13 13:40:25 2015] [error] [client xxx] CGI::Fast will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/libexec/munin/cgi/munin-cgi-html, line 30.
[Fri Feb 13 13:40:25 2015] [error] [client xxx] CGI::Carp will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/libexec/munin/cgi/munin-cgi-html, line 31.
[Fri Feb 13 13:40:26 2015] [error] [client xxx] [Fri Feb 13 13:40:26 2015] munin-cgi-html: Subroutine header redefined at /usr/libexec/munin/cgi/munin-cgi-html line 171.
[Fri Feb 13 13:40:26 2015] [error] [client xxx] [Fri Feb 13 13:40:26 2015] munin-cgi-html: Subroutine path_info redefined at /usr/libexec/munin/cgi/munin-cgi-html line 172.
[Fri Feb 13 13:40:26 2015] [error] [client xxx] [Fri Feb 13 13:40:26 2015] munin-cgi-html: Subroutine url redefined at /usr/libexec/munin/cgi/munin-cgi-html line 173.
[Fri Feb 13 13:40:26 2015] [error] [client xxx] [Fri Feb 13 13:40:26 2015] munin-cgi-html: Subroutine script_name redefined at /usr/libexec/munin/cgi/munin-cgi-html line 174.
[Fri Feb 13 13:40:26 2015] [error] [client xxx] [Fri Feb 13 13:40:26 2015] munin-cgi-html: Can't use an undefined value as an ARRAY reference at /usr/lib64/perl5/vendor_perl/5.20.1/Munin/Master/HTMLOld.pm line 694.

The problem begin with my upgrade to perl5.20
OS: Gentoo
Note: My version of munin is 2.0.25 but I cannot select it in the dropbox below

Change History (0)

Note: See TracTickets for help on using tickets.