#639 closed defect (fixed)

samba plugin (munin 1.3.4) has incorrect format of 'max' warning/critical values

Reported by: kozik Owned by: nobody
Priority: normal Milestone:
Component: plugins Version: 1.3.4
Severity: normal Keywords:
Cc:

Description

Samba plugin has incorrect format of 'max' warning/critical values.

Samba plugin with 'config' prints:

  max.warning 900
  max.critical 960

but id does not have any 'max' value (instead it has 'proc', 'lock' and
'share'). This results in fake munin-limit alerts:

  samba;max;unknown Value is unknown.
  samba;max;state unknown

Steps to Reproduce:

  1. Add samba plugin to munin-node configuration.
  1. Run /usr/libexec/munin/munin-limits
  1. Check file /var/lib/munin/limits

It is kinda annoying because it produces fake munin alerts.

Attachments (1)

munin-1.3.4-samba_plugin.patch (468 bytes) - added by kozik at 2008-11-26T09:15:59+01:00.
munin-1.3.4 samba plugin patch, fix for 'max' warning/critical values

Download all attachments as: .zip

Change History (2)

Changed at 2008-11-26T09:15:59+01:00 by kozik

munin-1.3.4 samba plugin patch, fix for 'max' warning/critical values

comment:1 Changed at 2008-12-05T14:18:02+01:00 by janl

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1776. Thanks very much!

Note: See TracTickets for help on using tickets.