#666 closed defect (fixed)

Munin-node help hardcodes path to conffile

Reported by: jwarnier Owned by: matthias
Priority: normal Milestone: Munin 1.2 running maintenance
Component: node Version: 1.2.6
Severity: normal Keywords:
Cc:

Description

"munin-node --help" shows /etc/munin/munin-node.conf as configuration file, whatever the real default is (example: on Solaris, confdir is in /etc/opt/munin).

Trivial to fix.

Change History (10)

comment:1 Changed at 2009-03-14T21:01:23+01:00 by janl

  • Owner changed from nobody to mathias

comment:2 Changed at 2009-03-14T21:50:10+01:00 by janl

  • Milestone set to Munin 1.2 running maintenance

comment:3 Changed at 2009-03-14T22:39:02+01:00 by janl

  • Owner changed from mathias to matthias

comment:4 Changed at 2009-03-25T09:48:57+01:00 by jwarnier

Duplicate of #673.
I thought I already submitted it, but could not find my report, so reported it again today.
Seems the "My Tickets" does not work at all...

comment:5 Changed at 2009-06-03T15:18:01+02:00 by tatjana

  • Owner changed from matthias to tatjana

comment:6 in reply to: ↑ description Changed at 2009-06-03T15:24:09+02:00 by tatjana

Replying to jwarnier:

"munin-node --help" shows /etc/munin/munin-node.conf as configuration file, whatever the real default is (example: on Solaris, confdir is in /etc/opt/munin).

Trivial to fix.

Same issue as #658.

This has been fixed in trunk, see r1860.

comment:7 Changed at 2009-06-03T15:31:57+02:00 by tatjana

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed at 2009-06-03T15:37:57+02:00 by tatjana

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed at 2009-06-03T15:38:37+02:00 by tatjana

  • Owner changed from tatjana to matthias
  • Status changed from reopened to new

comment:10 Changed at 2009-06-03T15:38:43+02:00 by tatjana

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.