#694 closed defect (fixed)

munin-node does not honor path to pid file

Reported by: jwarnier Owned by: nobody
Priority: normal Milestone: Munin 1.2 running maintenance
Component: node Version: 1.2.6
Severity: minor Keywords:
Cc:

Description

Whatever you set in Makefile.config, the pid file gets to /var/run/munin.
In munin-node script itself, it is hardcoded several times.

Change History (3)

comment:1 Changed at 2009-06-29T11:28:57+02:00 by jwarnier

Moreover, the "pid_file" setting in munin-node.conf has no visible effect.

comment:2 Changed at 2009-07-01T14:48:13+02:00 by jwarnier

Actually the same bug than #688.

comment:3 Changed at 2009-08-30T14:57:21+02:00 by matthias

  • Resolution set to fixed
  • Status changed from new to closed

If @@STATEDIR@@ is set to something other than /var/run/munin/ in Makefile.config and you 'rebuild' Munin by typing "make clean && make" in your munin source directory the path to the stae directory is set to the right value. I cannot reproduce the problem.

The other point: pid_file paramter in munin-node.conf is indeed useless because it will overwritten in munin-node during runtime. So i remove pid_file from munin-node.conf

Note: See TracTickets for help on using tickets.