#7 closed enhancement (fixed)

Keep more data

Reported by: jo Owned by: snide
Priority: high Milestone: Munin 2.0.0
Component: design Version:
Severity: critical Keywords: None
Cc: nobody

Description (last modified by snide)

Munin now keeps data for as short as neccessary (5-minute periods for the last day, 15-minute periods for a week, 30-minute periods for a month, and daily periods for a year), to use as small rrd files as possible.

It should support using larger rrd files which keeps high granularity data for longer periods. This is especially important in regards to implementing zoomable graphs.

Change History (13)

comment:1 Changed at 2006-06-19T23:47:53+02:00 by janl

  • Component changed from wiki to server
  • Owner changed from nobody to janl
  • Type changed from defect to enhancement

comment:2 Changed at 2006-06-19T23:48:05+02:00 by janl

  • Milestone changed from Z-later to Munin 1.4

comment:3 Changed at 2006-06-19T23:53:47+02:00 by janl

We need to tune new intervals of data-retention for the new frequent sampling feature.

comment:4 Changed at 2006-08-30T02:50:37+02:00 by janl

  • Component changed from server to design
  • Status changed from new to assigned

comment:5 Changed at 2009-02-27T10:38:04+01:00 by janl

  • Owner changed from janl to kjellm
  • Status changed from assigned to new

comment:6 Changed at 2009-10-20T16:11:17+02:00 by janl

  • Milestone changed from Munin 1.4 to Munin 1.6

comment:7 Changed at 2009-10-21T00:30:53+02:00 by janl

  • Version 1.2.3 deleted

comment:8 Changed at 2009-12-04T23:21:54+01:00 by janl

  • Milestone changed from Munin 1.6 to Munin 1.4.3
  • Owner changed from kjellm to Steve Schnepp

Almost a duplicate of the zoom ticket.

comment:9 Changed at 2009-12-07T08:35:11+01:00 by janl

  • Owner changed from Steve Schnepp to snide

comment:10 Changed at 2009-12-07T14:23:09+01:00 by snide

  • Status changed from new to assigned

comment:11 Changed at 2010-01-17T18:44:14+01:00 by snide

  • Description modified (diff)

Right now there is an option "graph_data_size" that has 2 values :

  • normal : the normal retention values
  • huge : 5 min for 400 days, no aggregation

Changing the option value will only be taken into account when creating the RRD file.

Maybe it would be nice to have a "custom" value, that takes some extra params to specify, well, custom values for RRAs.

And it would be nice to have a "resample" feature for when the value changes. Maybe only as an external tool, or only when the onld RRD file got renamed, since the resampling might take a while and is destructive in case the new RRD file has a lesser resolution.

comment:12 Changed at 2010-01-18T13:28:16+01:00 by janl

  • Milestone changed from Munin 1.4.4 to Munin 1.5

comment:13 Changed at 2010-02-14T13:51:07+01:00 by snide

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r3342.

The "resample" issue is taken by ticket #860.

Note: See TracTickets for help on using tickets.