#794 closed defect (duplicate)

munin-graph fails for quota-usage_

Reported by: gombasg Owned by: janl
Priority: normal Milestone: Munin 2.0.0
Component: master Version: 1.4.1
Severity: normal Keywords:
Cc:

Description

Hi,

munin-graph fails to graph the quota-usage_ plugin. The reason is that it can not calculate the name of the RRD file for the "root" user:

2009/12/10 16:40:13 [DEBUG] Processing field "root" [root].
2009/12/10 16:40:13 [DEBUG] service Services :: foo.bar :: quota_usage_datavg_public_lpds has 24 elements.
2009/12/10 16:40:13 [DEBUG] RRD name / filename: root / /var/lib/munin/--g.rrd
2009/12/10 16:40:13 [DEBUG] Field name after cdef set to cdefroot
[...]
2009/12/10 16:40:13 [RRD ERROR] Unable to graph /var/cache/munin/www/Services/foo.bar/quota_usage_datavg_public_lpds-month.png : opening '/var/lib/munin/--g.rrd': No such file or directory

The name of the RRD file looks correct for all the other users.

Gabor

Attachments (1)

diff (2.0 KB) - added by gombasg at 2010-01-25T12:57:08+01:00.

Download all attachments as: .zip

Change History (5)

comment:1 Changed at 2009-12-22T13:56:55+01:00 by janl

  • Milestone changed from Munin 1.5 to Munin 1.4.3

comment:2 Changed at 2010-01-18T13:31:38+01:00 by janl

  • Owner changed from nobody to janl

Hi Gabor,

Need a patch for this. No-one I know uses quotas and I have no idea what the correct setting here is.

Changed at 2010-01-25T12:57:08+01:00 by gombasg

comment:3 Changed at 2010-01-25T12:59:08+01:00 by gombasg

Hi,

I've attached a patch for the master that works here. The problem was that the master side used the string 'root' for internal purposes. I did a mechanical replace of the string 'root' to 'root'; someone who actually knows the master code should check if it is correct.

Gabor

comment:4 Changed at 2012-02-02T16:29:36+01:00 by snide

  • Milestone changed from Munin 1.4.4 to Munin 2.0
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #921

Note: See TracTickets for help on using tickets.