Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#854 closed defect (fixed)

Due to a typo in the plugin ping_ it is not possible for munin-node to ping an IPv6-addresses.

Reported by: tamiko Owned by: nobody
Priority: normal Milestone: Munin 1.4.4
Component: plugins Version: 1.4.3
Severity: normal Keywords:
Cc:

Description

Due to a typo in /usr/libexec/munin/plugins/ping_ it is not possible for
munin-node to ping an IPv6-addresses.

The last line should read "${PING:-ping} ...", not "${ping:-ping} ...".

See attached diff.

Attachments (1)

ping_.diff (640 bytes) - added by tamiko 4 years ago.
diff of /usr/libexec/munin/plugins/ping_

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by tamiko

diff of /usr/libexec/munin/plugins/ping_

comment:1 Changed 4 years ago by tamiko

Steps to Reproduce:

  • Create a symlink for pinging IPv6-hosts in /etc/munin/plugins , e.g. ping6_gw-3207.ham-01.de.sixxs.net -> /usr/libexec/munin/plugins/ping_
  • start munin-node

Actual Results:
Pinging fails.

Expected Results:
Pinging should succeed so that a nice graph can be plotted.

comment:2 Changed 4 years ago by snide

  • Milestone changed from Munin 1.5 to Munin 1.4.4

pushing it to 1.4.4 since it's a bug.

comment:3 Changed 4 years ago by knan

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, committed in r3374 for 1.4.4.

Note: See TracTickets for help on using tickets.