#868 closed defect (fixed)

munin-node-configure --debug bombs on tomcat_ plugin

Reported by: janl Owned by: ligne
Priority: high Milestone:
Component: node Version: 1.2.6
Severity: normal Keywords:
Cc:

Description (last modified by janl)

Hi,

Got this on IRC:

# munin-node-configure --debug --shell
...
DEBUG: Checking plugin: tomcat_...auto...autoconf...suggest...yes:no...Can't use string ("") as an ARRAY ref while "strict refs" in use at /usr/sbin/munin-node-configure line 603.

More was expected after that.

Nicolai

Attachments (1)

munin-bug-868.patch (339 bytes) - added by ligne at 2010-03-10T15:55:09+01:00.
a hacky fix

Download all attachments as: .zip

Change History (6)

comment:1 Changed at 2010-02-19T08:22:08+01:00 by janl

  • Description modified (diff)

comment:2 Changed at 2010-02-19T08:23:38+01:00 by janl

  • Description modified (diff)
  • Summary changed from munin-node-configure --debug bombs on tomcat_ plugins to munin-node-configure --debug bombs on tomcat_ plugin

comment:3 Changed at 2010-02-24T15:40:44+01:00 by knan

Looks like 1.2.x munin-node-configure talking. 1.4.x doesn't have that sort of debug output here...

# Considering '/scratch/munin-svn/sandbox/opt/munin/lib/plugins/tomcat_'
#       Reading magic markers.
#       Set family to 'auto'.
#       Capabilities are: autoconf suggest

Changed at 2010-03-10T15:55:09+01:00 by ligne

a hacky fix

comment:4 Changed at 2010-03-10T16:02:46+01:00 by ligne

  • Version changed from 1.4.3 to 1.2.6

it's definitely 1.2/1.3-era Munin.

i can't seem to reproduce this with 1.2.6, but i can see where the error is occurring ($ps->{$plug}->{'suggest'} is getting set to somewhere along the line), but i can't for the life of me see where that might be.

the patch i just added might act as a workaround. it just makes sure that the key is empty before querying the plugin for suggestions. this shouldn't cause any regressions, since anything in there will be blatted anyway.

sound good?

comment:5 Changed at 2010-03-17T15:27:58+01:00 by ligne

  • Resolution set to fixed
  • Status changed from new to closed

no complaints, so resolving fixed.

Note: See TracTickets for help on using tickets.