#887 closed defect (fixed)

$config->{rundir} not properly setup when _create_rundir_if_missing is called

Reported by: blueyed Owned by: nobody
Priority: normal Milestone: Munin 1.4.6
Component: master Version: 1.4.3
Severity: normal Keywords:
Cc:

Description

I've installed munin locally on Lucid, and it fails after reboot with the following errors:

Creating lock /var/run/munin/munin-limits.lock failed: No such file or directory

at /usr/share/perl5/Munin/Master/LimitsOld.pm line 114

Creating lock /var/run/munin/munin-graph.lock failed: No such file or directory

at /usr/share/perl5/Munin/Master/GraphOld.pm line 248

Creating lock /var/run/munin/munin-html.lock failed: No such file or directory

at /usr/share/perl5/Munin/Master/HTMLOld.pm line 151

The problem is that when _create_rundir_if_missing is run (from /usr/share/perl5/Munin/Master/Update.pm run()), $config->{rundir} is "/tmp" and exists).
Later however, $config->{rundir} gets mapped to $MUNIN_STATEDIR - which is /var/run/munin.

Normally, this bug gets worked around when munin-node is running on the same node, too - since the start script (upstart in Ubuntu) creates /var/run/munin.

The real bug appears to be that $config isn't properly setup when _create_rundir_if_missing is run.

Initially reported at https://bugs.launchpad.net/ubuntu/+source/munin/+bug/538587

Change History (2)

comment:1 Changed at 2010-09-14T22:48:45+02:00 by ligne

  • Component changed from node to master

comment:2 Changed at 2011-01-14T11:33:41+01:00 by jo

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in both the 1.4 branch (r4084) and trunk (coming 2.x branch, r4085).

Thanks for the report.

Note: See TracTickets for help on using tickets.